1.36.1
Changelog since v1.36.0
Changes by Kind
Bug or Regression
- DRA metadata read helper (KEP-5304): on decode skip only if version is unknown, return error if object/file is malformed (#138859, @alaypatel07) [SIG Node]
- Fixed kubelet failure starting on ZFS due to missing cadvisor plugin. (#138590, @BenTheElder) [SIG Node]
- Fixed stale remote HNS endpoint cleanup on Windows when a pod IP is reused across nodes in L2Bridge networks, preventing DNS timeouts caused by traffic being routed to the wrong node. (#138603, @princepereira) [SIG Network and Windows]
- Kube-proxy does not perform full-sync operations when operation in large cluster mode (more than 1000 endpoints) (#138635, @aojea) [SIG Network]
- Kubeadm: during 'kubeadm init', if the default 'admin.conf' and 'super-admin.conf' paths are used, load the files, but construct in memory kubeconfigs that point to the InitConfiguration.localAPIEndpoint instead of the ClusterConfiguration.controlPlaneEndpoint. This would resolve issues with delayed load balancers which are provisioned only after the first kube-apiserver instance starts. (#138682, @neolit123) [SIG Cluster Lifecycle]
- Kubeadm: skip LocalAPIEndpoint defaulting on 'kubeadm join' for worker nodes. (#138802, @neolit123) [SIG Cluster Lifecycle]
- Kubeadm: use a dedicated ClusterRole 'system:kubelet-api-admin' for the kube-apiserver kubelet client. (#138958, @neolit123) [SIG Cluster Lifecycle]
- Kubeadm: when checking the etcd cluster status use a quorum approach, instead of considering the health of all members. This would allow the check to not fail if there are sufficient healthy voting members. (#138538, @ahrtr) [SIG Cluster Lifecycle]
Dependencies
Added
Nothing has changed.
Changed
Nothing has changed.
Removed
Nothing has changed.