1.33.8
Changelog since v1.33.7
Changes by Kind
Feature
- Kubeadm: when patching a Node object do not exit early on unknown (non-allowlisted) API errors. Instead, always retry within the duration of the polling for getting and patching a Node object. (#136070, @neolit123) [SIG Cluster Lifecycle]
- Kubernetes is now built using Go 1.24.12 (#136468, @cpanato) [SIG Release and Testing]
Bug or Regression
- DRA: when scheduling many pods very rapidly, sometimes the same device was allocated twice for different ResourceClaims due races between data processing in different goroutines. Depending on whether DRA drivers check for this during NodePrepareResources (they should, but maybe not all implement this properly), the second pod using the same device then failed to start until the first one is done or (worse) ran in parallel. (#136565, @pohly) [SIG Node and Scheduling]
- Fixed SELinux warning controller not to emit events for completed pods. (#136172, @jsafrane) [SIG Apps, Storage and Testing]
- Fixed an issue in the Windows kube-proxy (winkernel) where IPv4 and IPv6 Service load balancers could be incorrectly shared, causing broken dual-stack Service behavior. The kube-proxy now tracks load balancers per IP family, enabling correct support for PreferDualStack and RequireDualStack Services on Windows nodes. (#136375, @princepereira) [SIG Network and Windows]
- Fixed kubelet logging to properly respect verbosity levels. Previously, some debug/info messages using V().Error() would always be printed regardless of the configured log verbosity. (#136434, @thc1006) [SIG Node]
- Kubeadm: waiting for etcd learner member to be started before promoting during 'kubeadm join' (#136365, @dlipovetsky) [SIG Cluster Lifecycle]
- Kubeadm: when applying the overrides provided by the user using "extraArgs", do not sort the resulted list of arguments alpha-numerically. Instead, only sort the list of default arguments and keep the list of overrides unsorted. This allows finer control for flags which have an order that matters, such as, "--service-account-issuer" for kube-apiserver. (#135851, @neolit123) [SIG Cluster Lifecycle]
Other (Cleanup or Flake)
Dependencies
Added
Nothing has changed.
Changed
- github.com/opencontainers/cgroups: v0.0.1 → v0.0.3
Removed
Nothing has changed.