Catalog / Kubernetes

1.32.12

8 months agochangedremovedOriginal notes

Changelog since v1.32.11

Changes by Kind

Feature

  • Kubeadm: when patching a Node object do not exit early on unknown (non-allowlisted) API errors. Instead, always retry within the duration of the polling for getting and patching a Node object. (#136069, @neolit123) [SIG Cluster Lifecycle]
  • Kubernetes is now built using Go 1.24.12 (#136469, @cpanato) [SIG Release and Testing]

Bug or Regression

  • DRA: when scheduling many pods very rapidly, sometimes the same device was allocated twice for different ResourceClaims due races between data processing in different goroutines. Depending on whether DRA drivers check for this during NodePrepareResources (they should, but maybe not all implement this properly), the second pod using the same device then failed to start until the first one is done or (worse) ran in parallel. (#136564, @pohly) [SIG Node and Scheduling]
  • Kubeadm: waiting for etcd learner member to be started before promoting during 'kubeadm join' (#136366, @dlipovetsky) [SIG Cluster Lifecycle]
  • Kubeadm: when applying the overrides provided by the user using "extraArgs", do not sort the resulted list of arguments alpha-numerically. Instead, only sort the list of default arguments and keep the list of overrides unsorted. This allows finer control for flags which have an order that matters, such as, "--service-account-issuer" for kube-apiserver. (#135850, @neolit123) [SIG Cluster Lifecycle]

Other (Cleanup or Flake)

Dependencies

Added

Nothing has changed.

Changed

Nothing has changed.

Removed

Nothing has changed.